Basic Web Page Authoring with Dreamweaver MX2004

Panels and Windows p. 2

Page Properties
   Page Title p. 4
   Background Image/Color p. 4

Add Text p. 5
Line Breaks p. 5

Format Text
   Size p. 6
   Color p. 6
   Font p. 6
   Alignment p. 6
   Style p. 6
   Spelling p. 7

Name and Save File p. 7

Preview in Web Browser p. 7

Links p. 7-8

Tables
   Inserting p. 9
   Table Properties p. 9
   Background Color/Image p. 10
   Formatting Individual Cells p. 10
   Merge and Split Cells p. 10
   Cell Width p. 10

Images
   Inserting p. 11
   Alignment p. 12
   Alternate Text p. 12
   Image Borders p. 12
   Horizontal and Vertical Space p. 12
   Links p. 12
   Rollover Images p. 12-13
   Copyright Issues p. 13-14

Uploading p. 14
Troubleshooting p. 17

View HTML Code p. 18

Named Anchors p. 19
Basic Web Page Authoring with Dreamweaver MX2004

Macromedia Dreamweaver is a sophisticated graphical HTML editor for the creation of professional-quality Web pages. Dreamweaver can be used to author a single Web page or to create and manage a multi-page site. The software allows the user to modify his or her work using a graphical WYSIWYG (What You See Is What You Get) interface while simultaneously viewing and editing the HTML source code. This handout will walk you through the process of creating a single Web page, including:

Objectives:

Trainees will be able to use Dreamweaver to create a webpage by:

- Changing page properties
- Adding and manipulating text
- Saving a webpage
- Adding internal and external hyperlinks
- Adding email hyperlinks
- Inserting images
- Adding and formatting tables
- Uploading a webpage
- Troubleshooting

Getting Started – Windows and Panels

1. Double-click the desktop icon to open the Dreamweaver program.

2. This is what opens:

![Macromedia Dreamweaver MX 2004 interface]

Go ahead and close the Panel Groups on the right by clicking the inward-pointing arrow that is located half way down the panel.
3. To get started on a new page, go to file and select new.

4. A window will pop-up. Select Basic Page and HTML (these are the defaults) and click create.

5. This is what will open:

If your Insert Bar or your Properties Bar (or any other bar) are not open, select Window from the Menu and click on the bar that you would like to see. A checkmark to the left of the window name indicates that the bar is open.

*Note if you lose your insert bar, click the menu button and select common*
Page Properties

Begin by setting the page properties. These are global properties that remain constant throughout the entire page (but not throughout the site). Select Modify>Page Properties from the Menu. The Page Properties dialog box appears.

1. Select a background color by clicking on the small gray box next to the word “Background color.” The Colors palette pops up. Use the eyedropper tool to select a color (note: many of the colors are repeated). Click Apply to preview the background color in the Document Window. Test different colors until you find one you like.

The background of the Web page can be filled with a solid color or an image. Background images are usually small (no more than 200x200 pixels) images that tile to fill the entire browser window. Background images should be used sparingly, as they easily overwhelm the rest of the page and make text difficult to read. Most professional Web pages have solid-colored backgrounds, perhaps with a patterned bar down one side of the screen.

2. Click in the small grey box next to the word “Text” to use the color palette to select a text color for the page. Text will appear in this color as it is typed, but color applied to individual characters, words, or sentences overrides this setting. If no color is specified the text will be black.
3. To set the color of links, visited links, and active links, you will need to click on the word “Links” in the Category box and then click on the small gray box next to each of the link options.

- A link is a character, word, or line of text that is clicked to take the user to another page. Links customarily differ in color from other text and are underlined, showing users where they should click to navigate to a page. The default color for links is blue.

- A visited link is a link to a page that was recently visited by the user. Links usually change color after they are visited to show users where they have and have not been. The default color for visited links is purple, and such links often stay purple for several days, even if the Web browser and/or computer are shut down and restarted. The amount of time that visited links remain purple (or whatever color you choose) depends on settings within the user's Web browser.

- An active link is a link that is being clicked. Active link colors often escape notice because they are displayed only while the mouse button is depressed, creating a flash of color. The default color for active links is red.

Page properties can be previewed at any time while the dialog box is open – simply click the Apply button. Once you are satisfied with your color choices, click OK. Page properties can be modified at any time by selecting Modify>Page Properties from the menu. You can also modify the page properties by clicking the Page Properties button on the Properties Inspector.

Text

To add text to a Dreamweaver webpage, position the cursor in the Document window where you would like the text to begin and start typing. Formatting can be applied in advance by pre-setting the Properties Inspector or can be applied after it is typed by highlighting (selecting) the text to be modified and changing any of the properties. At the end of a line, the text will wrap to the next line. Text in Web pages wraps to fit the width of the browser window.

If you do not want text to wrap, insert manual line breaks or paragraph breaks.

- Press Shift-Enter to insert a single line break. This creates the equivalent of single-spaced text.

- Press Enter to insert a paragraph break (this adds a blank line between lines of text, similar to double-spacing).
Text appears in size 3 Times New Roman font, the default font face and size for the World Wide Web. Remember that the options in the Properties inspector are used to format text (the same options can be accessed by choosing Text from the menu). Highlight (select) the text to be modified to change any of the properties.

1. Make the text larger. Select a number from the Text Size pull-down menu.

   If desired, assign a size relative to the basefont (default) size of 3 by selecting + or – 1 through + or – 7. This method is not recommended – it is best to stick to font sizes of 1 – 7.

   **A word about text sizes:** Dreamweaver specifies text size in the way Web browsers recognize it: as a number between 1 and 7 rather than a size like “12 point.” Here are rough equivalencies:

<table>
<thead>
<tr>
<th>HTML size</th>
<th>Equivalent point size</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>8 point</td>
</tr>
<tr>
<td>2</td>
<td>10 point</td>
</tr>
<tr>
<td>3</td>
<td>12 point</td>
</tr>
<tr>
<td>4</td>
<td>14 point</td>
</tr>
<tr>
<td>5</td>
<td>18 point</td>
</tr>
<tr>
<td>6</td>
<td>24 point</td>
</tr>
<tr>
<td>7</td>
<td>36 point</td>
</tr>
</tbody>
</table>

2. Click in the Text Color box and select a color from the Colors palette.

   This color overrides the global text and link colors set in the Page Properties dialog box.

3. Choose a font face from the Font Combination pull-down menu. Browsers display the first font from the selected group that is installed on the user’s system.

   If the font you want to use is not listed, select Edit Font List to create a custom font list. Be aware, however, that a user will not see that font unless it is installed on his or her computer. Dreamweaver’s pre-set font lists contain the most common fonts – the ones found on most computer systems, regardless of platform or operating system.

4. Use the alignment icons to select left, center, or right justification for text. These icons change the alignment of a word, line, or paragraph of text.

5. Click on the Text Indent icon to indent a single line of text or an entire paragraph. This simulates the effect of a left page margin. Indent is handy for offsetting sections of text such as quotes. Unfortunately, it is not possible to indent just the first line of a paragraph.

6. Use the Bold and Italics icons to change the text style.
7. Check Spelling: Place the cursor at the top of the Document window and select Text>Check Spelling from the Menu, or use the keyboard shortcut Shift+F7.

Save and Preview

1. Name and save the file. It is important to save early when working in Dreamweaver to create document-relative paths for links and images that will be added later. Document-relative paths ensure that the images will display in the page and the links will work correctly once you transfer your page to a Web server. If you insert links or images in the page before it has been saved the first time, a pop-up box will warn you that you need to save the file.

   a) Select File>Save from the Menu. The Save As dialog box appears.

   b) Choose a directory in which to save your file. Remember that an HTML document should be saved in the same place as its associated image files.

   c) Name your file. There should be no spaces in your file name. Also remember that it is best to give your file a short and uncomplicated name so that you will be able to access your URL quickly and easily!

   d) The correct file extension will be added to the filename.

   e) Click Save. Be sure to save often as you work on your page.

2. Preview your work in a Web browser by clicking the Preview in Browser icon in the toolbar or by going to File>Preview in Browser. This will launch a Web browser as long as one is installed on your machine. You can preview in a browser at any time while working in Dreamweaver. Be sure to close the browser window when you are finished, as the preview can not be reloaded or refreshed when more changes are made.

   It is a good idea to preview your page in a browser before posting it to a Web server. Previewing in a web browser is the only way to test links and other interactive features such as JavaScript rollovers before you post your page to the web.

   WARNING: Sometimes, after previewing your page in a Web browser, Dreamweaver displays a pop-up window warning that your page has been modified in another program and asking if you would like to save changes. Say NO – if you don’t, you will lose all of the changes made since the last save.

Links

Text can easily be made into a link to another Web page. Links can take the user to an external separate Web site, an e-mail composition window (this will only work if your Web browser is configured for e-mail), or to another page within your Web site.
Link to an External Web Site:

1. Select the word/s that will become the link.
2. Type the URL (address) of the target site in the blank **Hyperlink** field and press the **Enter** key. You **must** include the **http://** portion of the address, or your links will not work.

![Image of the Properties window with the Hyperlink field highlighted.]

Create an E-mail Link:

**Method One:**
1. Place the cursor where the e-mail link should appear.
2. Click on the **Insert E-Mail Link** icon in the insert bar. The Insert E-Mail Link dialog box appears.
3. Enter link text in the **Text** field.
4. Enter the e-mail address in the **E-mail** field.
5. Click OK.

**Method Two:**
1. Select the text that will become the link.
2. Type `mailto:` in the text field, followed by the desired e-mail address. Do **not** include a space after the colon. If the address is not preceded by `mailto:`, Web browsers will not recognize it as an address.

![Image of the Insert E-Mail Link dialog box.]

To Link to a Page Within Your Site:

1. Select the word or words that will become a link.
2. Click on the **Browse for File** icon in the Properties inspector.

![Image of the Select File dialog box.]

The Select HTML File dialog box appears.
3. Browse for the desired .htm or .html file. Click Select. The selected word/s in the Document window change color and become underlined to indicate that they are now a link.

1. **Be aware that when you browse for a file, Dreamweaver will often include the entire path in the hyperlink if your pages are not saved in the same place.** (It will look something like this: file:///C|/Documents and Settings/sultl/My Documents/webpages/gardeningpathfinder.htm) When this happens, your link will not work once the page is published. **Avoid this problem by removing everything but the name of the linked page and the .htm or .html extension (It should look something like this: gardeningpathfinder.htm)** or **by saving all of your pages in the same place.**

4. If you know the name of the file you want to link to, there is no need to browse for it – just type the filename and extension (ex: page2.html) in the Link field. Linking to a page in a different folder or directory requires that the entire path be entered in the Link field (ex: ../homepage/images/pix.html)

Links must be previewed in a Web browser – they do not work in the Dreamweaver interface!

### Tables

Tables are a very useful HTML tool. Two common uses for them are:

- **A traditional table with cells to display data in an organized fashion**
- **Page layout with tables.** Using tables with invisible borders for Web page layout allows for increased control over the appearance of a page. Tables can display images and paragraphs of text side-by-side and simulate page margins, among other things.

1. To add a table to your document, place your cursor in the desired location and click the **Insert Table** icon or select Insert>Table from the menu. The Insert Table dialog box appears.

2. Select the number of rows and columns you want in your table. Set the width of the table and its borders. All of these selections can easily be changed later.

3. Although the **Cell Padding** (which creates invisible space inside a cell’s border) and **Cell Spacing** (which increases the distance between cells) boxes appear blank, the default values for those settings are one pixel each. To change them to zero (if desired), you must manually type 0 in the boxes.
4. Click **OK** to add the table to you Web page. The table appears in the document window, and the Properties inspector changes to display table options. To modify the table at any time, move your mouse pointer to one of the four corners of the table until you see a with box with six squares then click to select.

5. To select a background color for the entire table, select the table and then click in the Background Color box.

6. To add an image or text, place the cursor in an empty cell and insert an image or begin typing. (Table cells can contain text, images, or even other tables.) Images can also be dragged and dropped into table cells. Cell borders automatically adjust to accommodate an image placed in a cell, but cells containing text must be resized manually. Click and drag cell borders to resize the table cells, or click and drag the right table border to change the width of the entire table.

7. To change the color of an individual cell, click inside a cell to select it and then click on the Bg box in the lower half of the Properties Inspector. Individual cell colors override the background color set for the entire table.You’ll notice that once you have clicked in an individual cell, the Properties Inspector gives you the option of merging or splitting cells.

8. To **merge cells**, click on the outer border of the cells you want to merge or click and drag (vertically, horizontally, or both) to select two or more adjacent cells and then click the **Merge** icon (located in the lower left corner of the Properties Inspector).

9. To **split cells**, place the cursor in the cell to be divided and then click the **Split** icon. The Split Cell dialog box appears.

   Select either Rows or Columns in the top portion of the dialog box, then use the arrows to select or type the desired number of rows or columns in the box below. Click OK. The cell is subdivided into several rows or columns without adding any additional rows or columns to the table.
Images

To insert an image into a page:
1. Place your cursor where you would like the image to appear.

2. Click on the Insert Image icon in the Tool Bar (or select Insert>Image from the Menu).

3. The Select Image Source dialog box appears. Browse for the image to insert, then click once on the desired image. A preview of the selected image appears in the image preview area. If you do not see a preview of the image, select the Preview box at the bottom of the dialog box.

   a. Be aware that when you browse for your image file, Dreamweaver will include the entire path in the hyperlink if your image is not saved in the same place as your webpage. (It will look something like this: file:///C|/Documents and Settings/sultl/My Documents/webpages/Index page/dozer2.jpg) When this happens, your image will not show up once the page is published. Avoid this problem by removing everything but the name of the image and the .gif, .jpeg, or .png extension. (It should look something like this: dozer2.jpg) or by saving your image in the same place that you saved your webpage.

   b. Remember that only GIF, JPEG, and PNG files can be inserted in pages.

4. Click Select. The image appears in the document window and the Properties inspector changes to reflect the appropriate options.
5. **To change where the image appears on the page.** Select **Text>Align** from the Menu, or click on one of the alignment icons in the lower half of the Properties inspector.

6. **Alternate text is an important addition to any webpage** that contains images. **Alt text** is the text label that pops up when the cursor is held over an image without clicking (see example at right). Add alternate text by typing a name into the **Alt** box on the properties inspector.

7. **Alt text** is a nice touch for users who can see your Web page, but it is essential for those who cannot see it. Users with visual impairments depend on screen reader software (such as JAWS) to read all of the text and links on Web pages. Unless you include an Alt text tag with a description, these users will not know what the images are and will be unable to navigate images used as links.

8. **To link an image to another webpage:**

9. Type a URL (Web address), .html file name, or e-mail address (including mailto:) in the **Link** text box, **OR** use the **Browse for File** icon to search for a file.

10. Although it is a **bad idea** to do so, images can be resized in Dreamweaver. This process changes the size at which the image is displayed rather than changing the dimensions of the source image. The image might appear quite small on the screen but still be a large file that takes a long time to download. To shrink the image dimensions **AND** file size, edit the image in an external editor (Photoshop, Paint Shop Pro, etc.). Making an image larger in Dreamweaver is also a bad idea because is results in a grainy, pixellated image. The image should be rescanned or recreated at a larger size.

11. **To change the image dimensions,** type a new value in the **W** and **H** text boxes, **OR** click and drag one of the handles on the side, corner, or bottom of the image, **OR** resize the image proportionately by clicking and dragging a corner handle. If your image becomes distorted or you change your mind about resizing, click on the **Refresh** button to return to the original dimensions of the image. To avoid having your webpage looking cluttered add **Horizontal and Vertical space.** These are minor adjustments that can make a big difference in a Web page. Unless empty space is added manually, images, text, and all other objects in a page will be so close together that they touch. To make text more readable and keep pages from looking cluttered, add a few pixels of empty horizontal space (left and right sides) or vertical space (top and bottom) to an image or table.

12. Although they are seldom seen on the WWW, images can have borders. Type a pixel size in the **Border** field in the Properties inspector to add a border of that width on all sides of the image. The drawback: borders will be one of only two different colors. Borders around image links will be the link color selected in the Page Properties dialog box, and all other borders will be the text color set in the Page Properties.

13. **To add a table for layout,** place your cursor to the right of an image and type few sentences. Notice how the first line of text appears on the same line as the image, and the rest wraps below the image. If you want to place more than one line of text next to an image you must use a table for layout.

---

**Rollover Images**

A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: the primary image (the image displayed when the page first loads) and the rollover image (the image that appears when the pointer moves over the primary image). When you create a rollover, both images must be the same size; if the images are not the same size, Dreamweaver automatically resizes the second image to match the properties of the first image.
1. Place the cursor in the Document window where you would like the rollover image to appear.

2. Click the dropdown arrow next to the Image icon on the Tool Bar.

3. Select Rollover Image from the dropdown menu.

The Insert Rollover Image dialog box opens.

4. Type a one-word name for the image, if desired, or accept the default name (Image1, Image2, etc.).

5. Type the filename of the Original (primary) Image, or click Browse to locate the file on disk. This is the image that will appear in the Web page when it loads.

6. Browse to locate the Rollover Image file. This is the image that will appear when the mouse rolls over it the Original Image.

7. Make sure Preload Rollover Image is checked. This will download both images into memory on the user’s computer, preventing any delay when the images swap.

8. If the image is a link to another Web page, type the link URL in the Go to URL box.

9. Click OK.

10. Preview the rollover image by selecting File>Preview in Browser from the menu or pressing the F12 key.

A word about using images on your webpages

Materials on the Web, including images, are protected by copyright, just like everything else. This means that when you want to use an image on your webpage you must either:

2. Obtain permission from the image’s copyright holder.

3. Only use images that are specifically labeled as “public domain” (see http://mciunix.mciu.k12.pa.us/~spjvweb/cfimages.html for a list of websites that house public domain images)
4. Use an image that you have created

5. Be sure that your use of the image qualifies as a “Fair Use”. Follow this link to learn how to apply the Four-Factor Test http://www.utsystem.edu/ogc/intellectualproperty/copypol2.html#test

**Repositioning**

Objects in the Document window can easily be moved and arranged.

a) To move text, select the text and choose **Edit>Cut** from the Menu. Reposition the cursor where you would like the text to appear and choose **Edit>Paste**.

b) To move an object such as an image, click and drag the object to a new location. Objects can be dragged higher or lower in a page, but not to the right or left. Use the alignment icons to change the horizontal positioning of an object.

**Uploading your WebPages to u.arizona.edu**

Only use this first set of steps if this is the first time that you have uploaded a webpage to the u.arizona.edu server. (If you have already set-up your public_html directory, skip to the instructions under the next grey box.)

1. Be sure that you have a U-System Account. (U-System accounts are not automatically established when you create an email account.) If you have not established a U-System Account, go to https://account.arizona.edu/, click on Create CCIT computer accounts, and add the U-System account. Once the account has been added (this can take up to 24 hours), follow the instructions below to set-up your default home page.

2. **ACTIVATE the public_html directory**

   a) Open the SSH Secure Shell Client (This program is located in the file transfer folder on the IC computer desktop.)
      (If you are uploading from home, the SSH software can be downloaded from http://www.u.arizona.edu/ssh/)

      (The screen below will appear)
b) Click on FILE, then on CONNECT

c) At the prompt, type `u.arizona.edu` as HOST NAME

d) Type in your u.arizona.edu account USER NAME

e) Click on CONNECT

f) (If a HOST IDENTIFICATION box appears asking "Do you want to save the new host key to the local database?"; click on YES)

g) At the prompt, type in your u.arizona.edu account PASSWORD

h) Click on OK

i) At the opening screen, type **4**, then press ENTER to use a menu interface

j) (If the user selects options #1 or #3 - to use a command line interface - or if they have previously selected a command line interface - they will need to type `exec menu` at the command prompt to continue this process.)

k) Type **m**, then press ENTER

l) From the **Welcome menu**, use the down arrow keys to scroll to and highlight Misc. and press Enter (this moves you to the Miscellaneous Commands menu)

m) From the **Miscellaneous Commands menu**, select Home Page and press ENTER (this moves you to the WWW Home Page – Create Your Own Homepage menu)

n) From the **WWW Home Page – Create Your Own Homepage menu**, use the down arrow key to scroll to and highlight Home Page and press ENTER

o) The home page address (URL) appears highlighted in the middle of the screen ([http://www.u.arizona.edu/~userID](http://www.u.arizona.edu/~userID))

p) If your home page address does not appear, go back through the steps and be sure that you did not miss one. Pay close attention to step n (where you have to highlight Home Page again) as it seems to be the one that trips people up.

q) Type **q** to quit; then type **y** at the "Are you sure you want to quit?" prompt

r) Go to FILE, then EXIT to close out the SSH Secure Shell Client

**s) This process only needs to be done once, not each time a new page is added to the account space.**
*Read this if this is the first time that you are uploading to the u.arizona.edu server*

In order to set your default home page, (http://www.u.arizona.edu/~userID) you must name the first file that you upload index.html. Naming your first file index.html allows you to set a gateway page that you can use to link to your other pages and gives you an easy to remember URL to share with instructors and friends.

Follow these instructions to copy/publish a web page to the server:

a) Locate all of the files and pictures that you want to upload to the web.

b) Open the SSH Secure Shell File Transfer Client. This is different from the Secure Shell Client that you used to create your public_html folder! Look for the folder with the blue bubbles around the tab. (The program is located in the file transfer folder on the IC computer desktop. If you have Secure Shell Client open, you can also open a File Transfer window by clicking on the icon (yellow folder) in the Secure Shell Client menu bar—and vice versa. It saves having to login twice.)

c) At the blank screen, press ENTER; or click on FILE, then CONNECT

d) At the prompt, enter u.arizona.edu as the HOST NAME

e) Enter your u.arizona USER NAME

f) Click on CONNECT

g) At the prompt, enter your u.arizona PASSWORD

h) Click on OK

i) Double click on the public_html folder on the right side of the screen (If you do not see a public_html folder, you most likely missed step n in the instructions above and will need to go back and set-up your public_html directory.)

j) Click on OPERATION, then on UPLOAD

k) Use the dropdown arrow next to the "look in" box to browse for the files that you want to upload.

l) Select the file you want to upload by clicking on it

m) Click UPLOAD

n) For each image you added on the web page, repeat steps 9 - 12 to upload the image files (.jpg or .gif) to the server Remember each and every graphics file associated with a web page must be uploaded to the u.arizona.edu server!
Check your work by launching a browser and entering the appropriate URL in the address bar. (The URL will look something like: http://www.u.arizona.edu/~userID/filename.html) For example: John Smith’s webpage about his vacation would look something like: http://www.u.arizona.edu/~jsmith/vacation.html *Remember that the spelling and punctuation of your URL must be an exact match to the file you have uploaded.

What to do if you can’t see your webpage:

1) **Check your URL.** (The URL will look something like: http://www.u.arizona.edu/~userID/filename.html) Remember that the spelling and punctuation of your URL must be an exact match to the file you have uploaded.

2) **Check your file extension.** Does your webpage end in .html or in .htm? If you don’t know, try both. *Dreamweaver pages usually end in .htm*

3) **Be sure that you have put the files that you want to post to the web in your public_html folder.** If you accidentally uploaded them outside of the public_html folder, you will not be able to see them.

4) Remember to hit the refresh button on your browser each time that you upload to the u.arizona.edu server. (If your browser is open and you do not hit refresh, you will not see the new material that you have uploaded.)

What to do if your internal webpage links don’t work:

1) Be aware that when you browse for a file, Dreamweaver will often include the entire path in the hyperlink if your web pages are not all saved in the same place. (It will look something like this: file:///C|/Documents and Settings/sultl/My Documents/webpages/gardeningpathfinder.htm) When this happens, your link will not work once the page is published. Avoid this problem by removing everything but the name of the linked page and the .htm or .html extension (It should look something like this: gardeningpathfinder.htm) or by saving all of your pages in the same location.

What to do if you can’t see your pictures:

1) Check your public_html folder to be sure that you uploaded all of your pictures. If they are still not showing up, look to see where you uploaded your pictures. For example, if you have put your webpage in a sub folder within the public_html folder, your pictures must be put there as well.

a. Be aware that when you browse for your image file, Dreamweaver will include the entire path in the hyperlink if your image is not saved in the same place as your webpage. (It will look something like this: file:///C|/Documents and Settings/sultl/My Documents/webpages/Index page/dozer2.jpg) When this happens, your image will not show up once the page is published. Avoid this problem by removing everything but the name of the image and the .gif, .jpeg, or .png extension. (It should look something like this: dozer2.jpg) or by saving your image in the same place that you saved your webpage.
For when you want to know more

Changing Views

Dreamweaver MX contains multiple viewing options.

The default view is Design view. Icons in the toolbar allow you to easily switch between Design view, Code view, and a split view.

**Design view** gives a preview of the Web page nearly the way it will appear in a Web browser. Text, images, and other page elements can be added in this view using the icons in the Objects palette (duplicated in the Insert menu).

**Split view** displays a split window with the HTML code for a Web page in the top half and the Design view of the page in the bottom half. Either view can be edited.
Named Anchors

Long text documents on the Web often have a menu at the top of the page that links to other parts of the same page. Named anchors are used to create links to another part of a page or to a particular point in another page. An anchor is a position placemarker in a document, and attaching a name to that anchor allows the anchor to be referenced in hyperlinks.

When a link to an anchor is clicked, the Web browser jumps directly to the desired portion of the page. Named anchors are often used to jump to a specific topic or to the top of a document, quickly taking your visitor to the selected position.

Insert an Anchor:

1. Place the cursor in the page where the anchor should be placed.

2. Select Insert>Named Anchor from the menu. The Insert Named Anchor dialog box appears.

3. Type the anchor name in the dialog box. Anchor names are subject to the same restrictions as file names: no punctuation, no spaces, and the text is case-sensitive. Click OK.

4. A yellow anchor symbol appears in the Document window. If no symbol is visible, select View>Invisible Elements from the menu. This symbol will not be visible when the page is viewed in a Web browser.

Link to an Anchor:

1. In the Document window, select the text or image from which to link.

2. In the Link field of the Property inspector, type a number sign (#) and the name of the anchor. For example:
   - To link to an anchor named “chapter1” in the current document, type #chapter1.
To link to an anchor named "chapter1" in a different document in the same folder, type `filename.html#chapter1`.

Modify an Anchor:

1. To move an anchor, click and drag it to a new location.
2. To change an anchor name, click on the yellow anchor symbol in the Document window. Type a new name in the Properties inspector.